Intermittent Timeout Issue - Service Requests & Security Console

Incident Report for Property Control

Resolved

The issue has been resolved.
Posted Apr 15, 2026 - 13:38 EDT

Identified

Some users are experiencing an unexpected timeout when writing but not yet submitting a Service Request, Incident Report, or Shift Log. If left idle for ~5 minutes, the page may refresh and work may be lost.
Workaround: Copy your draft into a notepad before stepping away.

We are actively working on a fix and will update this page when resolved.
Posted Apr 14, 2026 - 12:03 EDT
This incident affected: Web Application.